Element 3D OBJ Sequence Problem

Hello, I’m having a problem with Element 3D. As far as I know, Video Copilot doesn’t have an active subreddit or forum, so I’m asking here. I did post this in the after effects subreddit as well.

So I have a character model that I added animation to via Mixamo. I exported the animation into an .obj sequence using a third party plugin for Modo.The animation has 105 frames and is textured.

The problem.

When I import the .obj sequence into AE via Element 3D, I’m able to apply all of the textures (12 different material layers with 3-4 textures in each one). Everything looks great… until I go through the timeline. At frame 66, all of the materials get “switched”. So like the material for the arms will get switched for the belt. The material for the mask gets changed for the boots.

I went ahead and opened the first and last .obj’s in the sequence into Modo. I went ahead and chose the "arm"material layer and gave it a red material. In both .obj’s, the arms turn red.

To test even more, I went ahead and exported the last 10 frames in the .obj sequence and imported those into Element 3D. I did the same test and changed the material color for the arm texture and it came out red as well.

So I know the .obj’s are just fine, it’s the importing into Element 3D and at a random frame where the textures all switch up.

I exported 5 total animations and this is happening at random keyframes in all 5 when I import the .obj sequence into Element 3D and I cannot figure out what’s happening here.

Have you updated to the latest E3d rev? What renderer are you using? Have you tested the seq in any other programs yet? Have you tried importing just the seq unit that is rendering incorrectly?


I haven’t tried any other software to test the sequence yet.

I did make 2 new folders. Separating the sequences that did work and the ones with the switched textures.

Imported the sequences into e3d separately and the problem was still there. The first set of sequences work and the second were all switched up.

Though opening the individual .objs into modo to check the materials all showed that they were working correctly.

What I did end up doing.

Made 2 instances of e3d. The first one with the first chunk of animation for the working objs and the second had the second half. With the second one, I reapplied all of the textures. So now the textures flow right between the 2 instances of e3d

1 Like

Ok, so another route might be not pulling the textures into Element3d but instead…
hear me out…
import each into After Effects into their own sequences at their resolution.
Then refer to the layers to pull the textures into Element.
This also gives you insane control over the textures themselves.


Yeah that’s what I ended up doing. In 1 comp, I have 2 E3D layers that pretty much split the comp in half. The first E3D has the first half of the animation and the second has the second half (with the reapplied textures). So when I hit play, the animations and now textures run like it should.