Using the Alpha Channels in Vegas Pro 15

Using old tech because I’m not willing to shell out as a hobbyist just yet, but is it even possible to have Vegas Pro 15 register the alpha channels on the footage here? I’ve been looking for a solution ages but I don’t know if I should just stop.

Basically someone tell me to stop.

1 Like

Hey @mightydubz and welcome to the forum! I did a little searching and found that Vegas Pro 15 does support ProRes files but I couldn’t find specifics about if the alpha channel is supported or not.

Do you mind describing the issue you are having in a bit more detail? What are you seeing when trying to bring in a file with an alpha channel? What is one of the clips you have tried using that hasn’t worked? Any details you can think to share could be helpful.

1 Like

Love Vegas, haven’t used it in a bit but here’s what I remember…
it should support alpha channels, only way to find out is to load something on the timeline with a color background on a lower channel BUT…
you could try using the layer as Multiplied, Overlay, or Screen.
You could also go the long route and create an idendtical layer to use as your alpha target by going black and white (or greyscale, depends on your needs) and pointing at it from your fx layer.


No apologies needed for Vegas; I still have it on my windows box. When Premiere or Final Cut complained that they can’t/won’t open a clip, Vegas is always ‘bring it!’ I dumped Adobe some years ago…still have Vegas. :smiley:


Thanks everyone for jumping in to help @mightydubz! Welcome to the forum!


yoo, thanks. So for the most part the easiest way to do it, that works for any .MOV you render out from Vegas 15 mind you, is to insert footage, right click it on the timeline and go to properties>media and select it’s Alpha channel from there.

None of the options in there work. As I said before however, if you built something from scratch (as in not just re-rendering the stock footage you guys provide) and rendered it out as a .MOV with alpha, dropping it back in and selecting the alpha channel works perfectly.

I’m just assuming that the tech you’ve used to record and make your footage is just too powerful for this version of Vegas, which is fine and all. Just wondering when it’s time to accept that it’s time t stop looking. I’ll have a play with making masks, but I’m hoping I can have the ease of use here.

1 Like

yeah gonna give this a shot. Fingers crossed, and thanks!

1 Like

Also, it could be the bit rate you’re editing in?
I just know Vegas will handle these files.
Sorry I’m not much help from our studio but I only have Vegas in the home shop currently.

I don’t think that will work. I made a new project conforming exactly to the AFX footage and it still doesn’t register the alpha layer.

Thanks for more info! So if you were to render out a MOV from Vegas, the “Alpha channel:” option would allow you to choose something other than “Straight”? Do you know if the ProRes files you are rendering out with an alpha channel are ProRes 4444 with 12-bit color depth? Because I wonder if it’s something to do with the bit depth of the file and Vegas 15 not supporting that?

Yeah I believe that is the crux of it all. After deeper digging it is unfortunately not possible on this version of Vegas to take advantage of the alpha layer on these files. It is time to call it quits I think.

Thankyou so much for your time everyone! If anyone solves it, then there are a lot of people on the internet who’d love to hear how you did it, but frankly that’s just how it pans out when Apple is involved. Until I can try it on later versions of Vegas, I’ll just have to make do sharing After Effects when I’m able to.

Once more, many thanks! Have a good one y’all!

1 Like

Wait what?
What version of Vegas are you using?

Hate to hear that! There is also a free version of DaVinci Resolve that has Fusion built in for VFX if this helps you any.

Vegas Pro 15

I’ll give it a look, thanks!

1 Like